Visio 2013
Quick Guide

- Create a Basic Flowchart
- Connect Shapes
- Align & Layout options
- Diagram organisation options

www.le.ac.uk/itservices
Table of Contents

What is Visio? .................................................................................................................. 3
Different Diagram Types ................................................................................................. 3
Create a Basic Flowchart ................................................................................................. 5
Page Setup ....................................................................................................................... 8
Connect shapes ............................................................................................................... 9
More about connectors ................................................................................................. 11
Add Pages ...................................................................................................................... 14
Change the layout of your diagram ............................................................................. 15
Create a Process diagram ............................................................................................. 16
Add a hyperlink to a shape ............................................................................................. 18
Add connection points to a shape or picture .............................................................. 19
Cross-functional flowcharts ......................................................................................... 20
Background Pages ......................................................................................................... 22
Layers ............................................................................................................................ 24
Groups ............................................................................................................................ 26
Containers ...................................................................................................................... 27
Useful Visio Shortcuts .................................................................................................... 28
Further help .................................................................................................................... 29
What is Visio?

Visio is a quick and easy way to create diagrams that cover a vast array of subjects and professions. For example: Flowcharts, Organisation Charts, Timelines, Space Planning diagrams. All diagrams created using Visio are compatible with other Microsoft products, such as Word, Excel etc. Visio isn’t however a 3D design package like CAD.

Different Diagram Types

There are three main groups of diagrams types:

**Connected Diagrams**

As you would expect, these diagrams consist of shapes that are connected together by lines, to form relationships. Examples would be Flowcharts, Mind Maps, and Organisation Charts.
Block Diagrams

Block diagrams tend to be visual diagrams using graphics, images, shapes, colours, size to project their meaning.

Measured Diagrams

A measured diagram is a scaled drawing, e.g. an office plan. Shapes and objects that are created in a measured diagram would represent real physical objects.
Create a Basic Flowchart

In order to create a basic flowchart you have to select the correct template. Once you have opened Visio the start screen will appear.

1. Select the template **Categories** option.

2. Select the **Flowchart** template category and then choose **Basic Flowchart**.

3. Click the **Create** button

The template will open and you will see the Visio screen, along with the template stencils:
Add shapes

Shapes are added to your diagram when you select and drag them from a stencil onto the page.

Align shapes

When dragging shapes onto your diagram you will have noticed some horizontal and vertical green lines and arrows. These lines and arrows are part of the *dynamic grid* and are there to help you equally space and align the shapes.

- Use the green lines to align horizontally / vertically
- Use the green arrows to space out uniformly

Check the dynamic grid is turned on:

1. On the Ribbon, click the View tab
2. Ensure Dynamic Grid is selected in the Visual Aids group

Add text to a shape

When a shape is selected, simply type to add text. To edit the text, start double click on the text.
Add a stencil

Any number of different stencils can be used to create a diagram. To open another stencil:

1. Click the More Shapes menu to browse the shape and stencil categories
2. Select a stencil to open it

More about shapes

You will notice that shapes have two sets of handles.

Resize

The white handles are for resizing and are displayed when the shape is selected

Rotate

The white rotate handle is for rotating

AutoConnect

The Blue Auto Connect arrows indicate the connection points. These sometimes might also show as black squares
Page Setup

Before you add anything to the drawing page it is advisable to carry out the Page Setup procedure otherwise you may encounter problems at the printing stage. There are 2 options to consider here: Print setup and Page Size.

1. Right click on the Page-1 tab, at the bottom of the page - select Page Setup

2. Select the Print Setup tab from the Page Setup dialog box - choose the correct Paper size (usually A4), and select the Paper Orientation (Portrait or Landscape)

3. Select a Print zoom option. If you want the drawing to fit onto 1 sheet, use the Fit to option.

4. Select the Page Size tab - select Let Visio expand the page as needed. The Pre-defined size setting will ensure extra pages are not added.

5. Click OK
Connect shapes

Connectors are the lines between shapes. They have special behaviours:

- they stay glued to shapes if moved
- they can route around shapes
- they can be split in two to allow the insertion of new shapes
- They are deleted along with the shape they are connected to

You can connect shapes together using the **AutoConnect** arrows or the **Connector** Tool.

**AutoConnect**

To connect using the AutoConnect arrows:

1. Hover over a shape to see the AutoConnect arrows
2. Hover the mouse over an **AutoConnect** arrow, and a connector will appear
3. To accept the connector, click the mouse

The connector is glued to the shape. If the shape is moved the connector will move to the side of the shape that is nearest.
Connector Tool

Once the Connector Tool has been turned on you can drag from one shape’s connection point to another shape’s connection point, or to the shape itself. It is important to remember to turn the Connector Tool off once you have finished.

To turn the connector tool on:

1. On the Ribbon, click the Home tab.
2. In the Tools group, click the Connector button

Point to Point Glue

If you connect from and to a shape’s connection point (black squares) this is called point-to-point glue. A solid green circle appears on the connector that has been connected from and a white and green circle appears where the connection has been made to. This connection will remain even when the shape is moved, which may result in the diagram looking over complicated.
Connecting to the Shape

If you connect to a shape, by dragging the end of the connector over the middle of a shape, you will see a green box appear around the shape. If the shape is then moved the connector will move to the side of the shape that is nearest, resulting in tidy diagrams.

More about connectors

Once you have the connectors in place, you can add text or change their style and format.

Add text to connectors

You can add text to connectors in a similar way to that of adding text to shapes. For example, you can add a Yes and a No to the connectors leaving either side of a decision shape. Once text has been added it can be selected and repositioned.

1. Select the connector and type the required text

2. To move the position of the text, select the connector

3. Move the yellow square that appears on top of the text to the required position.
Connector style and format

To see the different style and formatting options:

1. Select the connector

2. On the Ribbon, click the Home tab and select the arrow next to the Line button in the Shape Styles group

The options that can be changed are:

- Line Colour
- Line Weight
- Line Pattern
- Arrow style

3. Right click on a connector to change the routing style
Adding additional shapes

To add an additional shape:

1. Drag and drop the shape over the connector. The connector will split to allow the insertion of the new shape.

Manipulate connectors

Connectors can be manipulated so that they flow around other objects in the diagram or to create something more interesting.

1. Select a connector
2. Press **Shift** and drag a connector handle to move the mid points
3. Press **CTRL** and drag a connector handle to create more complex moves
Line jumps
You can change the style of any line jumps that appear in your diagrams.

1. Right click the page tab at the bottom of the page and display the Page Setup dialog

2. Select the appropriate line jump option from the Layout and Routing tab.

Add Pages
A Visio document can have a number of different tabbed pages (similar to Excel). This will enable you to create different diagrams on each page, or create break-down diagrams from a complex original.

The quickest way to add a new page to your document is to:
- Click the Insert Page Tab at the end of the page bar.

You can Rename any of the pages by double-clicking on the page tab. You can also Reorder the pages by dragging page tabs.
Change the layout of your diagram

There are many different layouts a diagram can have. Once you have created your diagram it is possible to re-layout it. Doing this might help improve the design of your diagram.

1. On the **Ribbon**, click the **Design** tab
2. In the Layout group, click the **Re-layout page** button
3. Hover over and select an option from the categories given:
Create a Process diagram

Usually when you want to create a workflow or process diagram you will be working from something that has already been drawn up, hence you will know right from the start what connects to what. In this case it will be easier to create the chart automatically connecting the shapes as you go.

Before you create your first shape:-

1. On the Ribbon, click the Home tab
2. In the Tools group, click the Connector button
3. Drag the first shape onto the page
4. Continue to drag all the other shapes onto the page

As you do this the shapes will automatically connect to the shape that is currently selected.

Note: Once the Connector Tool has been selected you can select any shape, then drag on a new shape and they will automatically connect to each other.
Add Numbering to a Process

You can automatically number the steps in your workflow or process diagram using a Visio add-on. To access this add-on:

1. On the Ribbon, click the View tab
2. In the Macros group, click Add-Ons
3. Select Visio Extras then Number Shapes

The Number Shapes dialog box will be displayed.

4. Select the manually by clicking option if you want to manually assign numbers by clicking onto the shapes in turn.
5. Select the auto number option if you want to automatically number shapes in the order that they were created.

Other options are available in the Number Shapes dialog box.
Add a hyperlink to a shape

You might want a shape within your diagram to hyperlink to a sub-process, on another page tab, a web page or another file.

1. Select the shape from which you want the hyperlink
2. On the Ribbon, click the Insert tab
3. In the Links group, click the Hyperlink button.

The Hyperlinks dialog box will be displayed.

4. Complete the Address field for links to external documents and web pages or the Sub-address field for links to pages within the same Visio file
5. Click OK
6. Press Ctrl + click to follow the link from the shape
Add connection points to a shape or picture

1. On the Ribbon, click the **Home** tab
2. In the **Tools** group, click the **Connection Point** button
3. Select the shape or picture. A black line will appear around it.

4. Hold down the **CTRL** key whilst clicking on the required location to add the connection point.

The connection point will appear as a small red square, which will turn to black once the shape or picture is deselected.
Cross-functional flowcharts

If you are creating a cross-functional flowchart you will need to use swimlanes and phases to organise the steps. A swimlane is a container, which means that any shapes placed inside it will move when the lane is repositioned in the diagram.

You will need to open the Cross-Functional Flowchart template

1. On the **Ribbon**, click **File** tab, choose **New**
2. Select the **Flowchart** template category and then open the **Cross-Functional Flowchart**

3. Ensure you select **Metric Units**, and click **Create**
4. Select the orientation for your diagram, and click OK

To add additional swimlanes you can either:

- Drag the shape from the stencil onto the page
- Insert a swimlane from the Cross-Functional Flowchart contextual tab
- Pause over edges of swimlanes and select the “insert swim lane” arrow

Tips for using swimlanes:

- Swimlanes can be rearranged by dragging and dropping
- They can be resized by dragging the lines (no handles)
- Shapes can be moved from one lane to another
Background Pages

A background page can contain elements that show on the foreground of your diagrams, almost like a template for each diagram. Common elements like titles, borders and background art are put onto a background page. A background page is very similar to the Header/Footer view in Word, or the Slide Master view in PowerPoint.

To add a background page with background art and a title:

1. On the Ribbon, click the Design tab
2. In the Backgrounds group, click the Backgrounds button
3. Choose a background graphic
4. There is now a new page on the Page tab bar called vBackground-1 which contains the selected background graphics

More about backgrounds

You will have to assign the background page to your original diagram pages if it is not showing.

1. Right click on the page tab (e.g. Page-1) of the required diagram and select Page Setup.

The Page Setup dialog box will be displayed.

2. Display the Page Properties tab and choose the name of the background page from the Background options
3. Click OK
You can change any Visio page with colours, shapes, logos or titles into a background page.

4. **Right** click on the page tab (e.g. Page-1) of the required diagram and select **Page Setup**.

5. Display the **Page Properties** tab and change the page **Type** to **Background** in the **Page Setup** dialog box.

6. Click **OK**

**Add borders and titles to the background**

1. On the **Ribbon**, click the **Design** tab

2. In the **Backgrounds** group, click the **Borders and Titles** button

3. Choose one of the borders and titles from the gallery. The border and title will also have appeared on the **vBackground-1** page.
Layers

You can use layers to help add organisation to your Visio documents. A Layer is a named category to which any number of shapes from your diagram can be assigned. If you have used layers you can do things to entire categories of shapes at the click of a button.

Create a layer

1. Select an individual shape or all the shapes, you want assigning to a layer. (Use Shift + Click to select several shapes)

2. On the Ribbon, click the Home tab
3. In the Editing group, click the Layers button, select Assign to Layer
4. Click New
5. Enter a New Layer name

6. Click OK
7. Tick the appropriate layer name to add the selected shape(s) to the layer
8. Click OK

This same process can be repeated until you have multiple layers assigned.
Manipulate layers

Layer Properties are used to control and manipulate the layers.

1. On the Ribbon, click the Home tab
2. In the Editing group, click the Layers button and select Layer Properties

The Layer Properties dialog box will be displayed.

3. Select/deselect the options as necessary.
   - # Number of shapes assigned
   - Visible Whether the layer is visible. Hiding a layer lets you use the same drawing but for different audiences (people).
   - Colour Adds colour. Colours objects in a layer
   - Lock Can’t move any shape until unlocked. Example of this could be if you have a diagram of a room – lock walls, windows & doors so that you can play about with the furniture.
   - Active If ticked new shapes will be added automatically to this layer.

4. Select Apply to test the options
5. Click OK

You can add the Assign to Layer control button to the Quick Access Toolbar. This will allow you to quickly assign new or selected shapes to a layer.

- Right click on the Assign to Layer button, select Add to Quick Access Toolbar
Groups

Another way to keep related shapes together in a diagram is to group them. You might want to group together if:

- a number of shapes need to be grouped to form a logo a single shape
- or a number of shapes that form a particular part of a diagram (office layout)
- to move a number of shapes at the same time, or arrange them

To create a group:

1. Select the shapes you want to group together (either by CTRL + select, or by drawing an imaginary rectangle around all the shapes)

2. On the Ribbon, click the Home tab

3. In the Arrange group, click the Group button - select Group

The shapes will now be grouped together as one.
Containers

You can use a Container to organise your shapes. Containers are special shapes which can be used to visually group logically related shapes. A container shape is a rectangular shape with a title area. The container is placed around the selected shapes in the diagram. Shapes are moved, copied and deleted with the containers they belong to.

![container](image)

To add container:

1. On the Ribbon, click the Insert tab
2. In the Diagram Parts group, click the Container button
3. Select an appropriate container from the gallery
4. Add/move shapes into the container. The container border turns to green as you add the shape to it

Alternatively

- Select the shapes first, then insert the Container (as above)

The Container Tools contextual tab contains a number of useful features:

- Fit to Contents
- Automatic Resize
- Lock Container – to lock the container’s contents
- Disband Container – to delete the container but not the shapes contained within it
# Useful Visio Shortcuts

<table>
<thead>
<tr>
<th>To Do This</th>
<th>Do This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td>Press Ctrl + Shift + Left Click</td>
</tr>
<tr>
<td>Zoom in</td>
<td>Press Ctrl + Roll forward</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Press Ctrl + Shift + Right Click</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Press Ctrl + Roll backward</td>
</tr>
<tr>
<td>Select all shapes on a page</td>
<td>Press Ctrl + A</td>
</tr>
<tr>
<td>Select multiple shapes</td>
<td>Press Shift + click on each shape</td>
</tr>
<tr>
<td>Select multiple shapes</td>
<td>Left mouse drag rectangle around desired shapes</td>
</tr>
<tr>
<td>Deselect shapes</td>
<td>Click a blank area of the page</td>
</tr>
<tr>
<td>Deselect shapes</td>
<td>Press ESC</td>
</tr>
<tr>
<td>Duplicate shapes</td>
<td>Select shapes, then press Ctrl + D</td>
</tr>
<tr>
<td>Duplicate shapes</td>
<td>Select shapes, then Ctrl + drag</td>
</tr>
<tr>
<td>Edit existing shape text</td>
<td>Double-click the shape. If this doesn’t work, select the shape and press F2.</td>
</tr>
<tr>
<td>Repeat an action</td>
<td>Press F4 to repeat the last action</td>
</tr>
<tr>
<td>Return to the Pointer Tool</td>
<td>Press Ctrl + 1</td>
</tr>
<tr>
<td>Save your diagram</td>
<td>Press Ctrl + S</td>
</tr>
<tr>
<td>Connector Tool</td>
<td>Press CTL + 3</td>
</tr>
<tr>
<td>Access Page Setup dialog box</td>
<td>Right click a Page tab</td>
</tr>
<tr>
<td>Insert a Hyperlink</td>
<td>Press Ctrl + K</td>
</tr>
<tr>
<td>Draw perfect squares/circles</td>
<td>Hold Shift key down whilst drawing a Rectangle or Ellipse</td>
</tr>
<tr>
<td>View diagram as a full screen</td>
<td>Press F5</td>
</tr>
<tr>
<td>Exit full screen view</td>
<td>Press F5</td>
</tr>
<tr>
<td>Group selected shapes</td>
<td>Press Shift + Ctrl + G</td>
</tr>
<tr>
<td>Ungroup a group of shapes</td>
<td>Press Shift + CTRL + U</td>
</tr>
</tbody>
</table>
Further help

IT Service Desk

Ring 0116 252 2253 or email ithelp@le.ac.uk to report a problem.
Notes:
Notes:
For more information

IT Services
University of Leicester
University Road
Leicester, LE1 7RH, UK

w: www.le.ac.uk/itservices
t: 0116 252 2253
e: ithelp@le.ac.uk

© University of Leicester

All information in this document was correct at the time of going to press. However, changes and developments are part of the life of the University, and alterations may occur to the programmes and services described in this document.